MFA Doesn't Remember Browser for 30 Days: Troubleshooting
  • 10 Aug 2023
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MFA Doesn't Remember Browser for 30 Days: Troubleshooting

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Article Summary

Issue

A user configures their Multi-Factor Authentication (MFA) settings in Foundation Cloud products. The user receives a prompt to supply the secure MFA code upon next login. The user enters the code and selects the option to 'Remember this browser for 30 days'. 

This option, when successful, prevents the MFA prompt from appearing to that user for 30 days after the authentication. 

For some users, the MFA prompt is coming up again upon their next login rather than 30 days later. 

Cause

Foundation Cloud products use Cookies to track the 30-day period for which the MFA prompt should not appear. Cookies are small data files used by web servers and are saved in the user's web browser. 

When these Cookies are not created in the user's web browser, or they are removed, the systems cannot track the 30-day period correctly. This causes the MFA prompt to display upon next login rather than allowing the 30-day skip period. 

What prevents Cookies from getting created or retained in the web browser?

There are many reasons why a user’s browser does not create or retain cookies:

  1. The user’s browser settings may be configured to not allow cookies.
  2. The user’s browser settings may be configured to clear all cookies after closing the browser.
  3. The foundation’s IT staff may have implemented a configuration policy on workstations preventing cookies from being stored.
  4. Users may be browsing in “Private” or “Incognito” mode, which will prevent cookies from being stored.
  5. Users may be manually clearing browser cache (including cookies).

Resolution

Take browser specific troubleshooting steps to find out why Cookies are not created and/or retained in the web browser.

Use the links below for quick access to the web browser's FAQ page. 



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